[xdebug-general] xdebug doesn't return variables (error code 300)

From: Johannes Jarolim <johannes[@]jarolim.com>
Date: Sun, 13 Jul 2014 14:10:43 +0200

I'm trying to work with xdebug on my remote machine. The connection seems
ok since the execution stops if i set a breakpoint and i see the context of
the call ($_GLOBALS). But i can't look into the variables.

Enabled the remote_log on the server and see the following:

<- context_get -i 330 -c 1 -> <response xmlns="urn:debugger_protocol_v1"
xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="context_get"
transaction_id="330" context="1"><property name="$_COOKIE"
fullname="$_COOKIE" address="57264352" type="array" children="1"
numchildren="1" page="0" pagesize="30">*... huge response with all globals
...*</property></response>

<- property_get -i 331 -n $b -> <response xmlns="urn:debugger_protocol_v1"
xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="property_get"
transaction_id="331" status="break" reason="ok">*<error
code="300"><message><![CDATA[can not get property]]></message></error>*
</response>

I get the "can not get property" error every time i want to access the
value of a variable.

Server runs

   - Apache 2.2.7 vc9,
   - php 5.3.16 and
   - xdebug 2.2.5 on a
   - windows 7 32 bit machine.

I'm trying to debug from a client machine using netbeans 8.0.

Anyone an idea how i can solve that?
Would be really nice to be able to debug.

thanks for any help!

--
Johannes Jarolim, PMP
---------------------------
Senior Web Development
Maria Cebotari Stra├če 6
5020 Salzburg
+43 664 4047489
http://www.jarolim.com
office[@]jarolim.com
Received on Sun Jul 13 2014 - 13:10:45 BST

This archive was generated by hypermail 2.2.0 : Mon Jun 25 2018 - 06:00:04 BST