[xdebug-dev] Bug 0000239: Strings with null chars are not fully sent to the client

From: <noreply[@]lists.xdebug.org>
Date: Fri, 9 Feb 2007 20:48:37 +0100

The following bug requires your FEEDBACK.
======================================================================
http://bugs.xdebug.org/bug_view_page.php?bug_id=0000239
======================================================================
Reporter: bhofmann
Handler:
======================================================================
Project: Xdebug
Bug ID: 239
Category: Usage problems
Reproducibility: always
Severity: trivial
Priority: normal
Status: feedback
Operating System:
PHP Version: 5.1.6
Xdebug Version: 2.0.0rc2
======================================================================
Date Submitted: 2007-02-09 09:51 CET
Last Modified: 2007-02-09 20:48 CET
======================================================================
Summary: Strings with null chars are not fully sent to the client
Description:
The bug n0000228 is marked as closed but I still have it with the
2007-02-02 build from pecl
======================================================================

----------------------------------------------------------------------
 derick - 2007-02-09 20:48 CET
----------------------------------------------------------------------
I can not reproduce this with Xdebug-2.0.0rc4-dev with the script from that
bug report. It correctly replies:

(cmd) property_get -i 3 -n $a
<?xml version="1.0" encoding="iso-8859-1"?>
<response command="property_get" transaction_id="3"><property name="$a"
fullname="$a" address="-1215898560" type="string" size="36"
encoding="base64"><![CDATA[aGVsbG8KRGF2ZQBJIGhhdmUgYWRkZWQgYSBudWxsAG9yIDIK]]></property></response>

Please provide a script and which commands you are sending to the debug
client so that I can reproduce it.

Bug History
Date Modified Username Field Change
======================================================================
2007-02-09 09:51bhofmann New Bug
2007-02-09 09:51bhofmann Bug Monitored: bhofmann
2007-02-09 20:48derick Bugnote Added: 0000562
2007-02-09 20:48derick Status new => feedback
======================================================================
Received on Fri Feb 09 2007 - 20:48:56 GMT

This archive was generated by hypermail 2.2.0 : Sun Jun 24 2018 - 04:00:03 BST